How to fix “Lua: Error during loading” in Loading Wireshark on Kali Linux

Lua: Error during loading

Wireshark is very handy tool among Network Engineers, Pen-testers and anyone who cares about network traffic. You may install it on your Windows OS as well as Mac and Linux. Since it is installed by default on Kali Linux so you don’t need to install it on your Pentest machine.

Usually during my classes, participant complain a warning message during the initialization of the Wireshark. In this short tutorial I am showing you how to get rid of the following warning:

******

Lua: Error during loading:

[string “/usr/share/wireshark/init.lua”]:46: dofile has been disabled due to running Wireshark as superuser. See http://wiki.wireshark.org/CaptureSetup/CapturePrivileges for help in running Wireshark as an unprivileged user.

******

Lua: Error during loading

Open your terminal and type the following command to

Command: gedit /usr/share/wireshark/init.lua

Set the “disable_lua” paramter into the True value. Save the file and relaunch the Wireshark. You are good to go without any warning message.

Cheers!

Advertisements